Analytics Data not loading past 11/19/25

Incident Report for Moveworks GOV

Resolved

This incident has been resolved.
Posted Nov 26, 2025 - 16:59 UTC

Identified

We have identified an issue where analytics data is not loading past 11/19. The root cause has been identified and a fix is currently in place to resolve the issue.
Posted Nov 25, 2025 - 16:52 UTC
This incident affected: AI Assistant Analytics.